PostGIS

Splitgraph can also work with PostGIS, an extension for PostgreSQL that adds support for geospatial data. By default, due to space requirements, the Splitgraph engine image doesn't come with PostGIS installed, but you can upgrade your engine to use a PostGIS-enabled image (splitgraph/engine:[version]-postgis):

$ sgr engine upgrade --image splitgraph/engine:stable-postgis
$ sgr sql "CREATE EXTENSION IF NOT EXISTS postgis"

The PostGIS example will guide you through plotting a map of votes in New York City in the 2016 US Presidential Election using Splitgraph, PostGIS and GeoPandas.